Some EVH on my 1968 JMP 50W

For all things to build the brown sound

Moderators: VelvetGeorge, RACKSYSTEMS

mean_street
New Member
Posts: 18
Joined: Thu Sep 04, 2014 3:59 pm
Just the numbers in order: 13492

Some EVH on my 1968 JMP 50W

Post by mean_street » Sun Sep 24, 2017 1:41 pm

Hey guys,

I've just acquired an 1968 Marshall JMP 50W. Original transformers, largely untouched, some coupling caps and the filter caps have been changed. The first time I played it Ive been wondering that it has not the amount of gain I know from my other ´68 speced 100w amps (owned a 1959hw that I modded to 68 specs and currently own a Suhr SL68). :scratch:

Here is a clip, all controls on 10, Vol II at 3 or 4, Clinch Fx Ep-pre, guitar is a Gibson Les Paul with Bare Knuckle Mule Set.

https://soundcloud.com/benjamin-kreibe/ ... vh-content


Maybe someone can help me with this? :help:

Image
Image
Image
Image

Tazin
Senior Member
Posts: 727
Joined: Fri Jan 19, 2007 8:54 pm

Re: Some EVH on my 1968 JMP 50W

Post by Tazin » Sun Sep 24, 2017 6:43 pm

I don't think it sounds bad. It's sounds like it has enough gain but it's just a bit mushy sounding...It needs a bit of clarity and bite.

johnnybgoood
Senior Member
Posts: 99
Joined: Thu Feb 23, 2012 9:32 pm
Just the numbers in order: 7

Re: Some EVH on my 1968 JMP 50W

Post by johnnybgoood » Sun Sep 24, 2017 8:27 pm

Awesome acquisition! DO NOT MOD THIS AMP! *** See post below regarding bright cap.*** You have an incredible piece of history there!!!

"Want that VH1 tone? You gotta slave it...i would go as far as saying,..Edward did run this setup." -Rockstah RIP ( FYI https://en.wikipedia.org/wiki/Mark_Abrahamian )
viewtopic.php?t=20611&start=45#p207396

Examples of amp - slave amp setup.
TheMarshallmaniac - https://www.youtube.com/watch?v=d0uUXZejA_A

Jim Humble - https://www.youtube.com/watch?v=STj8RDDqbcY
https://www.youtube.com/watch?v=5A7MsY3hMGk
Last edited by johnnybgoood on Sun Sep 24, 2017 9:47 pm, edited 1 time in total.

johnnybgoood
Senior Member
Posts: 99
Joined: Thu Feb 23, 2012 9:32 pm
Just the numbers in order: 7

Re: Some EVH on my 1968 JMP 50W

Post by johnnybgoood » Sun Sep 24, 2017 8:48 pm

Ok I've calmed down. Your bright cap on the Volume 1 pot looks like it is soldered from wiper to ground. Please confirm yes or no. If yes, all your highs are going to ground. For '68 specs, the bright cap needs to be soldered from Pin 3 (input form the 0.0022 coupling cap) to Pin 2 (wiper) of Volume 1. This will give you more gain as all the highs from the 5000pf cap will directly go to the treble peaking circuit (470k/470pf) right before the second gain stage of V2a.

mean_street
New Member
Posts: 18
Joined: Thu Sep 04, 2014 3:59 pm
Just the numbers in order: 13492

Re: Some EVH on my 1968 JMP 50W

Post by mean_street » Mon Sep 25, 2017 3:49 am

Man, thank you so much! I will fix this immediately when I'm home from work. Yeah, somebody seems to have changed the pots, might reflow all the joints because some of them look suspicious.

mean_street
New Member
Posts: 18
Joined: Thu Sep 04, 2014 3:59 pm
Just the numbers in order: 13492

Re: Some EVH on my 1968 JMP 50W

Post by mean_street » Mon Sep 25, 2017 4:05 pm

So, I checked the bright cap now. It was soldered correctly, but one of its legs touched the back of the pot slightly. Just bended it a little bit away and the amp came to life. :rocker:

Many thanks for the tip! :toast:

Tazin
Senior Member
Posts: 727
Joined: Fri Jan 19, 2007 8:54 pm

Re: Some EVH on my 1968 JMP 50W

Post by Tazin » Mon Sep 25, 2017 4:09 pm

Good catch regarding the volume pot bypass cap. Now we need another sound clip to hear the amp in proper working order!

mean_street
New Member
Posts: 18
Joined: Thu Sep 04, 2014 3:59 pm
Just the numbers in order: 13492

Re: Some EVH on my 1968 JMP 50W

Post by mean_street » Tue Sep 26, 2017 4:33 am

Will make a clip today :thumbsup:

mean_street
New Member
Posts: 18
Joined: Thu Sep 04, 2014 3:59 pm
Just the numbers in order: 13492

Re: Some EVH on my 1968 JMP 50W

Post by mean_street » Tue Sep 26, 2017 11:59 am

https://soundcloud.com/benjamin-kreibe/ ... clip-fixed

Just a short clip of the sound now. Again: thank you all so much!

Tazin
Senior Member
Posts: 727
Joined: Fri Jan 19, 2007 8:54 pm

Re: Some EVH on my 1968 JMP 50W

Post by Tazin » Tue Sep 26, 2017 5:39 pm

mean_street wrote:
Tue Sep 26, 2017 11:59 am
https://soundcloud.com/benjamin-kreibe/ ... clip-fixed

Just a short clip of the sound now. Again: thank you all so much!
Sounds pretty good to me...It has that "typical" '68 lead sound.

Tazin
Senior Member
Posts: 727
Joined: Fri Jan 19, 2007 8:54 pm

Re: Some EVH on my 1968 JMP 50W

Post by Tazin » Fri Sep 29, 2017 6:04 pm

Did the previous owner mention why he changed all the potentiometers?

jnew
Senior Member
Posts: 1518
Joined: Mon Jan 07, 2013 9:34 am
Just the numbers in order: 13492
Location: Front Row Seat From the Outer Continental Shelf

Re: Some EVH on my 1968 JMP 50W

Post by jnew » Thu Nov 09, 2017 2:41 pm

That was a great observation and catch. Congrats on scoring that amp. It's a killer piece. You can also swap out the NFB resistor for 100K for more gain if you still need. 8)
________________________________
I SEE THINGS BETTER, WHEN I LISTEN


http://www.soundclick.com/bands/default ... ID=1214336" onclick="window.open(this.href);return false;

User avatar
efraser68
Senior Member
Posts: 1128
Joined: Fri Mar 28, 2008 6:13 pm

Re: Some EVH on my 1968 JMP 50W

Post by efraser68 » Thu Nov 16, 2017 3:18 pm

Sounds killer!! So you're not attenuating this at all? What speakers are you running? Would love to hear what the amp sounds like without the EP Pre.
Remember Ben Wise (aka Stunt Double) & Mark Abrahamian
http://www.soundclick.com/EricFraser" onclick="window.open(this.href);return false;

User avatar
MrBeasty
Senior Member
Posts: 626
Joined: Thu Jun 10, 2004 5:24 pm
Just the numbers in order: 7
Location: DC
Contact:

Re: Some EVH on my 1968 JMP 50W

Post by MrBeasty » Tue Feb 13, 2018 8:49 pm

Sounds stellar.

I had a 1970 JMP50 which I sold to get a JMP100, I always regretted it. This twists the knife a little.

User avatar
MrBeasty
Senior Member
Posts: 626
Joined: Thu Jun 10, 2004 5:24 pm
Just the numbers in order: 7
Location: DC
Contact:

Re: Some EVH on my 1968 JMP 50W

Post by MrBeasty » Mon May 07, 2018 1:12 pm

Just picked-up a '68 JMP50 ... it looks very similar, .68s on the pre-amp, etc.

Post Reply