67 Blackflag problem: Presence changes bias...

Everything from original vintage Marshalls to reissues.

Moderator: VelvetGeorge

Post Reply
MHProd
Senior Member
Posts: 137
Joined: Mon Mar 17, 2008 8:37 am

67 Blackflag problem: Presence changes bias...

Post by MHProd » Tue Jan 26, 2021 4:50 pm

My 100w dual rectifier blackflag started to ghost like crazy. One of the power tubes went bad (Mullard reissue) so I changed them for a new set I forgot I had (Ruby, which sound better and are more reliable). I also changed all the elytics as well and upped the values to make the amp a bit tighter. Ghosting is not completely gone but better, the amp is now usable... until I started to adjust the bias. It took me a while to figure out what was going on: the bias goes down significantly (-10ma) as soon as I turn the presence knob. It happens between 0 and 2. After 2 the bias doesn’t change...

I changed the PI caps (all 3 .1uf): no change.
Changed the bias supply caps: no change.

The presence pot sounds good, no scratches or noise.

What do you guys think?

danman
Senior Member
Posts: 955
Joined: Tue Sep 10, 2013 9:09 pm
Just the numbers in order: 13492

Re: 67 Blackflag problem: Presence changes bias...

Post by danman » Tue Jan 26, 2021 6:40 pm

Have you added any mods such as a PPIMV to the amp?

MHProd
Senior Member
Posts: 137
Joined: Mon Mar 17, 2008 8:37 am

Re: 67 Blackflag problem: Presence changes bias...

Post by MHProd » Thu Jan 28, 2021 3:15 am

Nope. All stock. I noticed it does it with the Treble pot as well, but only between 6 and 8, then the bias goes back up...

With V2 removed, the bias is stable. With V3 removed, the bias is stable too but it drops 10ma like when I turn the presence pot...

I don't get it.

Tazin
Senior Member
Posts: 753
Joined: Fri Jan 19, 2007 8:54 pm

Re: 67 Blackflag problem: Presence changes bias...

Post by Tazin » Thu Jan 28, 2021 9:55 am

If your running a stock grounding system (potentiometer buss ground wire) make sure the everything has good continuity to the chassis.

User avatar
neikeel
Senior Member
Posts: 7214
Joined: Tue Dec 06, 2005 8:31 am
Location: Suffolk, England

Re: 67 Blackflag problem: Presence changes bias...

Post by neikeel » Thu Jan 28, 2021 12:44 pm

Tazin wrote:
Thu Jan 28, 2021 9:55 am
If your running a stock grounding system (potentiometer buss ground wire) make sure the everything has good continuity to the chassis.
Good call
Check your bias caps have their own ground (to the nearest output tube socket ground).
Similarly run the presence pot ground to the PI cap ground.
Your tone stack and preamp can share a ground)
Neil

MHProd
Senior Member
Posts: 137
Joined: Mon Mar 17, 2008 8:37 am

Re: 67 Blackflag problem: Presence changes bias...

Post by MHProd » Thu Jan 28, 2021 1:53 pm

Thanks guys, I’ll try that.

Roe
Senior Member
Posts: 5050
Joined: Thu Apr 13, 2006 1:36 pm
Just the numbers in order: 7
Location: Drontheim. Norwegen
Contact:

Re: 67 Blackflag problem: Presence changes bias...

Post by Roe » Sun Feb 21, 2021 11:08 am

See if the board is conductive, esp. Between the 220k bias splitters and the 82k and 100k plate resisors
http://www.myspace.com/20bonesband" onclick="window.open(this.href);return false;
http://www.myspace.com/prostitutes" onclick="window.open(this.href);return false;
Super 100 amps: 1202-119 & 1202-84
JTM45 RS OT JTM50 JMP50 1959/2203/34/39

MHProd
Senior Member
Posts: 137
Joined: Mon Mar 17, 2008 8:37 am

Re: 67 Blackflag problem: Presence changes bias...

Post by MHProd » Mon Feb 22, 2021 4:34 pm

I’ve checked all the grounds, replaced the nfb wires so they are far from everything, tried changing all the caps, measured all resistors. No change.

I grounded the preamp and the issue is still there, so it comes from the power stage. If I lift the nfb resistor, the issue goes away, the bias is stable but lower by a few ma which I think is normal. I mean that the issue actually increases the bias current... what could cause this?

How can I check if the board is conductive? Simple conductivity test with my meter or? This is really puzzling...

danman
Senior Member
Posts: 955
Joined: Tue Sep 10, 2013 9:09 pm
Just the numbers in order: 13492

Re: 67 Blackflag problem: Presence changes bias...

Post by danman » Mon Feb 22, 2021 6:38 pm

Can you check to see if the plate voltage or B+ voltage falls when this issue occurs? I'm wondering if you have some sort of oscillation in the circuit. You would most likely see the plate voltage fall and the dissipation go up as the power amp tries to amplify the oscillation.

MHProd
Senior Member
Posts: 137
Joined: Mon Mar 17, 2008 8:37 am

Re: 67 Blackflag problem: Presence changes bias...

Post by MHProd » Tue Feb 23, 2021 12:19 am

Yes, the plate voltage increases as the current goes down.

Where could the oscillation be coming from?

danman
Senior Member
Posts: 955
Joined: Tue Sep 10, 2013 9:09 pm
Just the numbers in order: 13492

Re: 67 Blackflag problem: Presence changes bias...

Post by danman » Wed Feb 24, 2021 6:55 pm

I'm sorry but I was thinking backwards. I thought your current draw was increasing, which should cause the plate voltage to drop if the amp was experiencing an oscillation. When you mentioned that the problem occurred when using the treble and presence knobs it made me think that the circuit may be oscillating.

Oscillation can occur in an unstable circuit and adding more treble will usually make the issue worse as the amp tries to amplify frequencies above our normal hearing range. Bad lead dress is one cause of the problem and a careful rerouting of the preamp wires will normally help. Careful placement of the presence pot wiring is also crucial to prevent the issue. Some builders will add snubbing cap in amps that have this issue frequently and can't be removed by lead dress adjustment. Your symptoms seem a little different though and I'm not sure what would cause it. Hopefully someone will chime in with some other suggestions.

Post Reply